Page tree
Skip to end of metadata
Go to start of metadata
Inhalt

> Home

Index:


Hier findest du Informationen zum Open Roberta Lab und zu unserem "Open Roberta Betriebssystem" (auch Open Roberta Firmware genannt). Zunächst beschreiben die Menüpunkte im Open Roberta Lab und was sich hinter den Menüpunkten verbirgt. Wir haben versucht, das Open Roberta Lab so einfach wie möglich aufzubauen.

Es gibt fünf Menüpunkte links: Bearbeiten - RoboterHilfeBenutzer - Sprache.

Die Menüpunkte werden nachfolgend beschrieben.

Am rechten Rand des Open Roberta Labs befinden sich vier Schaltflächen, über die ergänzende Fenster auf- und zugezogen werden können:


Bearbeiten-Menü

In diesem Teil des Menüs findest du alles, was du mit deinem Programm machen kannst. Zusätzlich kannst du hier einstellen, mit welchen NEPO-Blöcken du programmieren möchtest.

starte auf dem Roboter

Mit einem Klick auf diesen Untermenüpunkt startest du das Programm auf dem Roboter. Dazu wird dein Programm und die Roboterkonfiguration an den Open Roberta Server geschickt. Dort wird daraus der vom Roboter lesbare Maschinencode generiert und an den Roboter geschickt. Der Roboter startet das Programm, sobald er es vollständig erhalten hat.

Wenn kein Roboter verbunden ist, erhältst du direkt eine Meldung. Du kannst eine bestehende Verbindung an der farbigen Roboterbezeichnung links oben im Menü erkennen.

Das »Starten« eines Programmes kannst du an verschiedenen Stellen im Open Roberta Lab und auf deinem Roboter erkennen:

  1. Oben in der Mitte des Open Roberta Labs erscheint für kurze Zeit eine Meldung, dass dein Programm nun verarbeitet wird.
  2. Auf dem Roboter erscheint das NEPO Logo, bevor es mit dem eigentlichen Programm losgeht.
  3. Während dein Programm ausgeführt wird, blinkt oben links im Menü die Roboterbezeichnung.

Du kannst ein Programm auch mit einem Klick aus dem Programmierbereich starten

starte in der Simulation

Mit einem Klick auf diesen Untermenüpunkt startest du das Programm in der Simulationsumgebung. Dein Programm wird an den Open Roberta Simulator geschickt und direkt ausgeführt. Die Roboterkonfiguration des simulierten Roboters beruht auf der Standardkonfiguration.

neu ...

Hier kannst du ein neues Programm erzeugen.

Bevor du ein neues Programm erzeugst, denke daran, dein altes Programm zu speichern!

Meine Programme ...

Zeigt alle deine gespeicherten Programme an. Hierfür musst du dich im Open Roberta unter »Benutzer« anmelden bzw. ein neues Benutzerkonto anlegen.

 Mehrere Roboter simulieren ...

Du kannst zwei oder mehr Programme in der Simulationsumgebung starten.

Voraussetzungen:

  1. Angemeldeter Benutzer
  2. Mindestens zwei gespeicherte Programme

Beispielprogramme ...

Wähle eines der gespeicherten Beispielprogramme, um dir den Einstieg zu erleichtern.

 speichern

Wenn du eingeloggt bist und dein Programm mit »speichern unter« bereits einen Namen bekommen hat, kannst du hiermit Änderungen in deinem Programm speichern. Dieselbe Funktionalität wird über den Knopf in der rechten unteren Bildschirmhälfte bereitgestellt. Speicherort ist die Open Roberta Cloud.

 speichern unter ...

Wenn du eingeloggt bist, kannst du in diesem Menü dein Programm unter einem von dir gewählten (neuen) Namen abspeichern.

zeige Quellcode

Der Programmcode in Java wird in einem einrollenden Fenster dargestellt.

 exportiere Programm

Das aktuelle Programm wird in eine XML-Datei exportiert und auf deinem lokalen Speichermedium gespeichert.

  importiere Programm

Es wird ein Programm aus einer XML-Datei importiert, d.h. von einem lokalen Speichermedium geladen.

Achtung! Beim Import eines Programms wird das aktuelle Programm überschrieben. Du solltest es unbedingt vorher speichern.

 NEPO-Blöcke Anfänger

Mit einem Klick auf dieses Menü wird nur eine bestimmte Auswahl der im Open Roberta Lab zur Verfügung stehenden NEPO-Blöcke angezeigt.

 NEPO-Blöcke Experte

Wenn du eingeloggt bist, kannst du mit einem Klick auf NEPO-Blöcke Experte alle im Open Roberta Lab zur Verfügung stehenden NEPO-Blöcke freischalten.



Hilfe-Menü

Das Hilfemenü verlinkt auf das Open Roberta Wiki. Zusätzlich stehen folgende weitere Untermenüs zur Verfügung:

Allgemeine Hilfe

Direkter Link in das Open Roberta Wiki mit umfassenden Informationen zum Projekt und zur Programmierung mit NEPO.

Programmieren mit NEPO

Direkter Link in das Open Roberta Wiki mit umfassenden Informationen zum Projekt und zur Programmierung mit NEPO.

Roboter vorbereiten

  • gegenwärtig nicht verfügbar

FAQ

FAQ steht für Frequently Asked Questions, auf deutsch: Häufig gestellte Fragen.

Fragen, die sehr häufig an uns herangetragen wurden, sind auf einer Seite zusammengestellt und bieten Antworten zu den Fragen.

Über

Hier findest du ein paar Informationen zum Projekt Open Roberta und zum Fraunhofer-Institut IAIS.

Starthinweis anzeigen

Wenn du auf dieses Untermenü klickst erscheint das am Anfang gezeigt Pop-Up Menü in dem unter anderem die aktuellsten Neuerungen im Open Roberta Lab aufgeführt werden. 

Logging

Zeigt dir alle deine Aktionen an, die du im Open Roberta Lab durchgeführt hast.




Benutzer-Menü

Mit diesem Menü kannst du dich im Open Roberta Lab anmelden, abmelden oder dir einen neuen Benutzerkonto anlegen bzw. einen bestehendes Benutzerkonto löschen. Hierfür stehen dir folgende Untermenüs zur Verfügung:

anmelden

Mit einem bestehenden Benutzerkonto anmelden. Wenn du noch kein Benutzerkonto hast, besteht die Möglichkeit, ein neues Konto anzulegen.

abmelden

Das angemeldete Benutzerkonto verlassen. Du kannst aber weiterhin NEPO-Programme schreiben und auch auf deinen Roboter übertragen.

ändern ...

Ändere einzelne Angaben zu deinem Benutzerkonto, wie den Benutzernamen, den Anzeigenamen, die E-Mail-Adresse oder das Passwort. Wenn du deine E-Mail-Adresse noch bestätigen musst, kannst du dir hier die Bestätigungsmail auch erneut zusenden lassen.

Benutzer löschen

Löscht dein Konto und alle deine darin gespeicherten Programme.

Statusinformationen

Es werden Informationen angezeigt, wie Benutzername, aktueller Programmname, Roboterkonfiguration und der gewählte Benutzermodus.




Sprachen-Menü

Das Open Roberta Lab wird in immer mehr Sprachen übersetzt. Wähle aus, in welcher Sprache dein Programm angezeigt werden soll.

Die angebotenen Hilfen sind gegenwärtig nur in deutscher und englischer Sprache verfügbar. Wenn eine nicht-deutsche Sprache ausgewählt wurde, gibt es die Hilfsinformationen in englischer Sprache.




Open Roberta Sim

Die Simulationsumgebung Open Roberta Sim ermöglicht es, Programme zu testen. Das ist insbesondere immer dann von Vorteil, wenn gerade kein Roboter-Modell zur Verfügung steht.

Open Roberta Programme können gleichermaßen auf einem realen Roboter oder in der Simulation ausgeführt werden. In der Simulation steht allerdings (gegenwärtig) nur ein einfaches 2D Roboter-Modell zur Verfügung, so dass eventuell nicht alle Programmbefehle ausgeführt werden können.



Wie komme ich zur Simulationsumgebung?

Die Simulationsumgebung mit einem einfachen 2D Roboter-Modell wird angezeigt, wenn im Programmierfenster am rechten Rand die SIM-Taste für die Simulation angeklickt wird. Daraufhin wird das Simulationsfenster aufgezogen. Es kann über die gleiche Schaltfläche wieder geschlossen werden.






Das 2D Roboter-Modell

Für die Simulation ist ein Roboter-Grundmodell verfügbar.
Das Simulationsmodell für EV3 verfügt aktuell über folgende Komponenten:
  • Aktoren
    • 2 über Motoren angetriebene Räder
    • 1 LED, die rot, orange oder grün leuchten kann
  • Sensoren
    • 1 Farbsensor, mit dem Farben auf dem "Boden" erkannt werden können
    • 1 nach vorn gerichteter Ultraschallsensor
    • 1 Berührungssensor im Stoßfänger

Diese vorhandenen Komponenten können in Simulationsprogrammen eingesetzt werden.

Simulationsmodelle anderer Roboter weichen vom EV3-Simulationsmodell ab.






Ein Programm mit Open Roberta Sim starten

Ein Simulationsprogramm wird im Simulationsfenster über die Start-Schaltfläche für die Simulation gestartet.

Das Anzeigefenster wird verändert.

  • Im linken Teil wird ein Auszug des Programms dargestellt.
  • Unten links im Simulationsfenster befinden sich Schaltflächen zur Steuerung der Simulation.
  • Im rechten Teil wird der 2D-Roboter in der aktuell gewählten Umgebung gezeigt.








Steuerungsfunktionen innerhalb von Open Roberta Sim

Unten links im Simulationsfenster befinden Schaltflächen zur Steuerung der Simulation.

Die angebotenen Schaltflächen im Simulationsfenster sind für die verschiedenen Robotersysteme unterschiedlich.

In der Abbildung sind die Schaltflächen für EV3 dargestellt.







Mehrere Roboter simulieren

Du kannst zwei oder mehr Programme in der Simulationsumgebung starten.

Vorgehensweise:

  1. Melde dich im Open Roberta unter »Benutzer« an. Wenn du noch kein Benutzerkonto hast, erstelle eins.
  2. Wenn du eingeloggt bist und bereits mehrere Programme abgespeichert hast, fahre mit dem Schritt 4 fort.
  3. Solltest du noch keine Programme besitzen, erstelle zwei oder mehr Programme und speichere sie in deinem Benutzerkonto ab. 
  4. Mit einem Klick auf »Bearbeiten > Mehrere Roboter simulieren« öffnet sich ein Auswahlfenster, in dem du die Programme zur Simulation auswählen kannst. Nach Auswahl der Programme öffnet sich die Simulation mit je einem Roboter für jedes Programm.
  5. Führe die Programme wie in der normalen Simulation über den Start-Knopf aus.


Die Ansicht der Sensordaten oder die Ansicht des Systems kann über Doppelklick auf den jeweiligen Roboter oder über das Dropdown Menü in der Ansicht der Sensordaten gewechselt werden.



Anzeige des Roboter-Bausteins

Mit der Anzeige des Roboter-Bausteins können Anzeigen im Display verfolgt werden.

Es stehen alle programmierbaren Tasten des Bausteins zur Verfügung.

Die Statusleuchte eines EV3 kann grün, orange oder rot leuchten.





  • No labels